Problema comunicazione tra NAS e Windows 10
  • NejiroNejiro
    Posts: 2,350Member
    Salve a tutti, ho un problema che non riesco a risolvere purtroppo e quindi chiedo aiuto a chi magari è riuscito a risolverlo.....Il mio sistema è composto da due Nas Synology in rete domestica, Windows 10, Foobar e applicazione da smartphone per controllare Foobar, praticamente diverse cartelle mi escono con dei caratteri strani come da foto, su Linux non ho questo problema in quanto ho installato il server CIFS e vedo i Nas come fossero cartelle, infatti li tutti i nomi sono giusti....Su Foobar ho caricato la libreria impostandogli il percorso da esplora rete di Windows e proprio qui credo nasce il problema, esiste un modo per far si che i Nas siano visti da Windows come faccio su Linux?In quel modo credo il problema si risolve, ma non sò come fare.....
    GrazieImmagine
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • Stefano74
    Posts: 14Member
    Ciao,

    ho trovato questo googlando velocemente sulla rete:
    "Hi,
    Had same problem, some directories showed in windows (smb access) with random names, while on Ubuntu (NFS mounted) the directories where human readable.
    The affected directories where on the root of the shared folder, and appeared to have a space as last character on their name. This is hard to spot in a gui. Removing the trailing space the directories showed as human readable names in the windows explorer. Naming in a 8.3 format was in this case not needed. But the remark put me on the right track."

    Veririca se le cartelle che hai creato hanno uno "spazio" alla fine, e rimuovilo.
  • bibo01bibo01
    Posts: 5,713Member
    Io per Windows e Synology faccio così...non so se risolve il tuo problema.
    In File Services di Disk Station abilito Windows share, In Windows File Manager vedo DiskStation sotto Rete. Da lì vedo tranquillamente la cartella Public e le sottocartelle. 
  • NejiroNejiro
    Posts: 2,350Member
    Grazie per le risposte....

    @Stefano74 Come ho già detto con Ubuntu dopo che ho installato Cifs/Server e modificato il file fstab per far caricare le cartelle dei Nas all'avvio e vederle come normali cartelle non ho problemi, anche senza usare NFS, praticamente quello che hai trovato grazie a google dice che le cartelle hanno uno spazio sull'ultimo carattere, sinceramente non riesco a capire e inoltre non posso andare a controllare tutte le cartelle, vorrei risolvere il problema a monte dato che con Linux non ho problemi.....

    @bibo01 non ho la voce "Windows share", gentilmente mi diresti dove la trovo?Ho la versione del DSM 6.1.3


    image
    Post edited by Nejiro at 2017-10-24 18:48:02
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • luca.urbinatiluca.urbinati
    Posts: 234Member
    Controlla di non aver usato caratteri non supportati nei nomi delle cartelle. Ad esempio i due punti :
    Usa il file browser del Nas per rinominare le cartelle incriminate.
    Windows non supporta alcuni caratteri nei nomi di file e cartelle, quando gli viene presentato, perché il Nas usa un altro file system che invece li supporta, questo è quello che succede.
    AudioLinux Roon HQPlayer + sMS 200 NAA / ifi micro iusb3 NS I2Usb NS Extremo / AES Three AES Two / JBL 4319 / Sunfire HRS 10 / cavi Silcable, VDH, WW e AQ
  • NejiroNejiro
    Posts: 2,350Member
    Grazie @luca.urbinati lo so che è quello ma non c'è nulla per risolvere?Non ho nulla con i due punti : con Windows 10 posso usare solo SMB o supporta qualche altro protocollo?Il problema credo sia quello ma non conosco altro su Windows oltre SMB......
    Grazie
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • luca.urbinatiluca.urbinati
    Posts: 234Member
    Con Windows nativamente solo SMB. I'll Nas dovrebbe avere un'interfaccia web per sfogliare il file system. Da lì dovresti capire quali sono le cartelle che non riesci a visualizzare e rinominarle, oppure eliminare il carattere non supportato.
    Se questa interfaccia web non è disponibile potresti usare un altro sistema operativo da altra macchina, ad esempio Linux o Mac rispettivamente con protocollo NFS o AFP.
    AudioLinux Roon HQPlayer + sMS 200 NAA / ifi micro iusb3 NS I2Usb NS Extremo / AES Three AES Two / JBL 4319 / Sunfire HRS 10 / cavi Silcable, VDH, WW e AQ
  • NejiroNejiro
    Posts: 2,350Member
    Ce l'ho l'interfaccia web ma da li come riconosco le cartelle incriminate?Tra l'altro sia sull'applicazione per smartphone della Synology che su Ubuntu sono tutte nominate giuste le cartelle.....certo se ci fosse un modo per riconoscere quelle che non vanno bene per windows già sarebbe qualcosa altrimenti è impossibile passarle tutte....
    Grazie
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • luca.urbinatiluca.urbinati
    Posts: 234Member
    Dovresti confrontare i due elenchi di cartelle e capire quali mancano su Windows. Mi rendo conto che non è ne semplice ne rapido. Se sono molte cartelle io proverei a spostarle un gruppetto alla volta sotto Linux/web e vedere su Windows se qualche cartella incriminata scompare. Sicuramente ne esci solo se ti metti di buzzo buono a spulciare le cartelle. Non ho mai sentito di un tool software che si occupi di normalizzare i nomi per NTFS proveniendo da EXT3 o EXT4, ma forse esiste.
    AudioLinux Roon HQPlayer + sMS 200 NAA / ifi micro iusb3 NS I2Usb NS Extremo / AES Three AES Two / JBL 4319 / Sunfire HRS 10 / cavi Silcable, VDH, WW e AQ
  • NejiroNejiro
    Posts: 2,350Member
    Cmq non credo sia una questione di caratteri non supportati da Windows, faccio un esempio, se ho una cartella di nome "pippo" che su Windows vedo con quei caratteri strani basta che la vado a rinominare con un nome a piacere tipo "pippo1" e poi la rinomino di nuovo "pippo" magicamente poi al prossimo riavvio Windows quella cartella me la vede bene.....
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • luca.urbinatiluca.urbinati
    Posts: 234Member
    Non sempre il problema dei caratteri tra file system diversi è appariscente. Il fatto che rinominando le cartelle risolvi mi fa pensare che sia proprio queato il problema.
    Per mia esperienza il problema è facilmente riproducibile inserendo un carattere non supportato da Windows usando un altro Sistema.
    Non ti nascondo che potrebbe esserci un problema a livello di gestione del file system sul Nas, ma la trovo una possibilità assai poco probabile.
    AudioLinux Roon HQPlayer + sMS 200 NAA / ifi micro iusb3 NS I2Usb NS Extremo / AES Three AES Two / JBL 4319 / Sunfire HRS 10 / cavi Silcable, VDH, WW e AQ
  • Stefano74
    Posts: 14Member
    Nejiro said:

    Cmq non credo sia una questione di caratteri non supportati da Windows, faccio un esempio, se ho una cartella di nome "pippo" che su Windows vedo con quei caratteri strani basta che la vado a rinominare con un nome a piacere tipo "pippo1" e poi la rinomino di nuovo "pippo" magicamente poi al prossimo riavvio Windows quella cartella me la vede bene.....




    Post edited by Stefano74 at 2017-10-25 17:20:52
  • Stefano74
    Posts: 14Member
    La cartella che vedi con nome strano in Windows, come la vedi sotto Linux? Hai verificato se il nome contiene caratteri "illegali" per Windows?
  • NejiroNejiro
    Posts: 2,350Member
    Sotto Linux dopo che ho installato cifs/server e modificato il file fstab per far montare i Nas all'avvio le vedo perfettamente, come le vedo perfettamente da browser con il sistema Synology e le vedo perfettamente anche con l'applicazione per smartphone della Synology, il problema è solo con Windows e samba.......
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • NejiroNejiro
    Posts: 2,350Member
    Cmq questo problema non si risolve e mi chiedo se sono solo io ad averlo.....
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • emaspacemaspac
    Posts: 5,330Member
    come li hai caricati sulla NAS? con Windows Explorer o Internet Explorer?
    leggi qui:


    dovresti sempre caricare i file tramite un FTP compatibile con UTF-8.
    Windows non supporta a pieno la codifica UTF-8


  • emaspacemaspac
    Posts: 5,330Member
    samba ovviamente tenta di far digerire a windows i caratteri non supportati... eliminandoli.

  • NejiroNejiro
    Posts: 2,350Member
    emaspac said:

    come li hai caricati sulla NAS? con Windows Explorer o Internet Explorer?

    leggi qui:


    dovresti sempre caricare i file tramite un FTP compatibile con UTF-8.
    Windows non supporta a pieno la codifica UTF-8




    Grazie per la risposta....infatti credo che il problema ce l'ho su quelli che ho caricato precedentemente tramite samba, da quando uso Linux e cifs/server non ho problemi.....c'è un modo per andare a correggere quelle cartelle che ho caricato precedentemente?
    Grazie
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • emaspacemaspac
    Posts: 5,330Member
    emaspac said:

    come li hai caricati sulla NAS? con Windows Explorer o Internet Explorer?

    leggi qui:


    dovresti sempre caricare i file tramite un FTP compatibile con UTF-8.
    Windows non supporta a pieno la codifica UTF-8




    Grazie per la risposta....infatti credo che il problema ce l'ho su quelli che ho caricato precedentemente tramite samba, da quando uso Linux e cifs/server non ho problemi.....c'è un modo per andare a correggere quelle cartelle che ho caricato precedentemente?
    Grazie



    purtroppo io penso che non ci sia modo. se invece Synology fosse un qualsiasi server Samba su Linux potresti provare quello che c'è scritto qui:


    cioè aggiungere al file (a tuo rischio e pericolo!):

    /usr/syno/etc/smb.conf

    mangled names = no
    dos charset = CP850
    unix charset = UTF-8
  • emaspacemaspac
    Posts: 5,330Member
    dopo aver editato il file, dovresti ristartare il Samba server.
    CP850 è il set di caratteri Latin-1: dovrebbe utilizzare quelli quando monta le cartelle su Windows....
    non ti assicuro nulla.
  • NejiroNejiro
    Posts: 2,350Member
    Grazie di tutto, farò un pò di prove.....
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II
  • NejiroNejiro
    Posts: 2,350Member
    Cmq pensavo una cosa....appurato il fatto che quelle cartelle che ho con caratteri strani dipende dal fatto che le ho messe nel Nas tramite il protocollo Samba che non supporta tutti i caratteri e quindi Windows va in tilt, le cartelle però stanno pur sempre nel Nas e se le "leggo" da Ubuntu, da applicazione Synology o dal browser del sistema Synology le leggo correttamente, non esiste un modo per far si che anche Windows le legga correttamente?Magari installando qualcosa, boh....
    Grazie
    Mcintosh C2200/MC402 - Chord 2Qute - Vandersteen 2CE Signature II